Thursday, June 16, 2011

How to use Old Addons in Mozilla FireFox

DISCLAIMER: This does not work for all addons!


When going to a Mozilla FireFox add-on download page (eg. https://addons.mozilla.org/en-US/firefox/addon/cookieswap/), the extension does not work on my 4.0.1 browser. Check your FireFox version by clicking Help > About FireFox.

We must change its compatibility by downloading the add-on. Dont click download directly because it tries to install the addon and will say the version is too old, so Right Click and Save Link As.. and save the ".xpi" file. (eg. https://addons.mozilla.org/firefox/downloads/latest/3255/addon-3255-latest.xpi)

The downloaded ".xpi" file is simply a ".zip" file. Double-click on the file and open it up and edit the "install.rdf" file. Change the "*.*.*" to the version of your browser. (eg. 4.0.*), leave the *(wildcard) at the end for further updates.

Source List
http://www.palaestratraining.com/blog/2008/07/firefox-3-make-older-add-ons-to-work/
http://kb.mozillazine.org/Install.rdf